
MAPMAKING FOR NEWBIES TUTORIAL

The goal of this tutorial is to allow you to make a playable map for Myth II Soulblighter
starting from scratch. By “scratch” I do not mean a total conversion where you create
your own units, scenery and sounds, but rather I will walk you through the process of
making a color map, reflection map, overhead map, and netgame preview before
launching into Fear and Loathing.  Other tutorials tend to skip these steps by simply
providing the above items for you. This tutorial assumes you have not made a map before
and will attempt to lead you through the most basic steps.  I’ll try and focus on the
common areas that are often overlooked in the various “instructions” that are out there
(they just assume you would know something so simple).  I’ll also try and lead you
through solutions to many of the common problems that are asked about frequently in the
various forums.  The end product will be quite basic, but should give you a start into the
world of mapmaking.

In no way is this simple tutorial meant to replace some of the more detailed and extensive
efforts that are available elsewhere.  By far the most notable of these is the Myth II
Handbook (http://www.myth2handbook.com) by J. Charles Holt.  If you decide you like
mapmaking, this is the book for you.  The extensive tutorials in mapmaking, scripting,
and unit modification will help you get a much better understanding of Fear and
Loathing.  Even if you don’t like mapmaking, the book is well worth its cost for its
sections with strategies and easter eggs, as well as inside information on Bungie.  Other
than being born in the same town (many, many years earlier), I have no association with
Mr. Holt: this is an honest plug from an unbiased consumer.

BEFORE YOU BEGIN:

This tutorial map was made on a G3 Mac using Photoshop 5.0, Fear and Loathing, and
Amber v2.0b5.  If you have a Mac, you will need a copy of Amber for the reasons
described below. You can download Amber from http://vista.theresistance.net/amber/.
Photoshop is the most common image editing program used to make color maps.  It is
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now available in a LE version for just $99. If you don’t have Photoshop, I’ve included a
completed color map (or you can download it from our site http://killermac.com/hpd).
You can also try your own image editing program.  I plan to have tutorials using other
programs such as Bryce 4 out soon.

The files included with the tutorial include 2 patterns, a graphic of archers, the completed
colormap, water map, overhead map, and netgame preview.  I’ve also included the final
map as a plugin so that you can check your work.

You will need the latest versions of Fear and Loathing in order to use this tutorial. You
can get the “Myth II Tools Updater v1.2” from the Bungie website or our “downloads”
page.  The original Fear and Loathing are located on your Myth II disk and need to be
installed via a “custom” install before you can update them.  Be sure to install them into
your Myth II folder or they won’t work.

General Tips for Fear and Loathing:

Your Myth II CD includes instructions for these programs (under “Tools Documents”).
Although foreboding, try and at least read through them.  I’m assuming for this tutorial
that you have read them and are as confused as I was.  I also recommend, if you use a
Mac, dedicating more memory to each program using “Get Info”. Try and not have other
programs open when you have either Fear or Loathing open.  Save often! – they can be
quite unstable.

The way I think about these programs is analogous to the theatre.  Loathing allows you to
edit the stage and position characters, while Fear allows you to edit the characters
themselves along with other items.  The stage is called a “mesh”.  Units, good or bad, and
wildlife are all called “monsters”.  Scenery is either an “object”, or a “model”.  Water in
Myth II is referred to as “media”.  Remember that, “media”=water.  However, the
media(water) is sometimes referred to as “reflection”– just for fun :-)

LET’S BEGIN!

If you’ve made maps for other games such as Marathon or Quake, you may remember
being able to create an environment out of polygons (the mesh), and then using a pop up
menu to apply surfaces (textures) to walls, the ground, etc.  The tools for Myth use the
same concept, with one exception – there are no “stock” textures that you can pop in
from a menu.  In fact, there aren’t any textures at all!  These have to be created by you
before you open Loathing to create the mesh.  You then import them into the program.
To make things even more difficult, in Loathing you don’t get to import a variety of
textures and then start pasting away to make the grass green and the rivers blue.  Nooo! -
that all has to be put together in your own image editing program and then imported as
one “color map” – a top down two dimensional image of your entire environment.

For this reason, our journey begins in Photoshop.  I am certainly not the artist of the
group, but,  if I can do this - you can. The goal of the following is to create a simple color
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map from basic items you can find around the house.  More complex color maps will
follow. Our artist, King Adrock, will be publishing much more detailed tips and tutorials
for Photoshop soon.

You can download or obtain textures and patterns from a variety of sources.  Many sites
have libraries you can download for free.  Most graphic and design programs such as
those from Adobe, Macromedia, Metacreations, etc. have folders of textures and patterns
as well as extra ones you can install from the CD.  For this tutorial I used “blue wave”
and “grass tiny” patterns.  They are included with this package, or can be downloaded
from our tutorial site.

Open Photoshop and use the File menu to open the “blue wave” and “grass tiny” patterns.
Now open the File menu and create a new file.  Don’t click “OK” just yet.  Here is the
first quirk of color maps – their size has to be a multiple of 256 pixels.  In the dialog box
that pops up when you create a new file, change the “inches” to “pixels” for the “width”
and “height” parameters(if necessary).  Now enter numbers that are multiples of 256 for
each. The average network maps in Myth II are 1024 X 1024.  For this tutorial, enter 512
X 512 (Interestingly, a 256 X 256 map will crash when you try to import it into
Loathing). Change the resolution to “72” and make the “mode” RGB color (Myth can
only use “indexed color”, but, we will change it to that later).  Click “OK”.

Now let’s make some grass.  If you simply pasted the “tiny grass” pattern into the new
file it would be too small.  If you enlarged it, you would just see huge pixels.  You can
make it a repeating pattern, however.  The files I’ve chosen were picked because they
“tile” seamlessly.  What this means is if you make many copies of the image and then
place them all next to each other in rows and columns, you can’t see where one begins
and the other ends.  Many desktop images or “wallpaper” work the same way.



Use the “Window” menu to bring the “grass tiny” image to the forefront.  In the “Select”
menu choose “All”.  Now look under the “Edit” menu and select “define pattern” – this
makes the image a pattern that can be “filled” into a selected area in another image.  Now
click on the blank new image or use the “Window” menu to bring it to the foreground.
Under the “Edit” menu choose “Fill…”(since the image is blank you don’t have to select
anything, it will fill the entire canvas).  In the dialog box that pops up where it says “use”
choose “pattern”.  Leave the blending at 100% opacity and “normal” mode.  Click “OK”
You have grass!

The grass you have is too detailed and would look “surreal” if you were to use it in Myth,
however.  Textures in Myth need to be a little more “Crayola” looking, or pastel.  No
problem.  That’s what is fun about Photoshop – a filter for every need!  I’ll use some
basic ones here. Again, I’m not the artist.  I encourage you to experiment with each of the
filters to see what they do.  If you hit on something you like, write down the path that you
took to get there and use it for your own maps.

With the new image still in the forefront, go under the “Filter” menu and select
“BluràBlur more”.  This blurs the image - duh.  Now go under the Filter menu again and
select “ArtisticàPalette Knife”.  The dialog box that pops up should be set to 25 for
stroke size, 3 for detail, and 0 for softness.  How did I come up with those numbers? –
trial and error! Click “OK”.  Now the grass looks more along the lines of those seen in
the color maps from Myth.  The repeating pattern is more obvious, but for now that’s
OK.  As you will see in the next section you can paste patterns into shapes you’ve
selected or you can even paint them over a specific area of the canvas.  We won’t do a lot
more for the sake of this tutorial, but hopefully you can see how creating a beautiful color
map with icy rivers and rocks jutting out of the snow can be done with a lot of time,
patience, and the ability to “see” what your 2D image will look like in 3D.



Let’s add a pond to the center of the image.  Water in Myth (“media”, remember?) is
defined by both the color map, as well as the “reflection map”.  The color map
determines what you see on the surface of the water.  The reflection map tells loathing
what part of the color map is water and therefore should have the water “properties” as
defined by the “media” tags.  We are going to make both of these maps in Photoshop
now, and will use Layers to make them line up correctly.

With the new image still in the foreground, make sure the “Layers” palette is open.  If
not, go under the “Window” menu and select “Show Layers”.  Click the triangle on the
top right of the Layers palette to open a pop up menu and select “new layer”(you can do
this from the “Layer” menu at the top of the screen as well, but the palette should still be
open as it makes switching between layers easier once they are created).  Be sure the
opacity is 100% and the “mode” is normal. Click OK.  In the Layers palette you should
now see 2 layers, one called “background”, the other “layer 1”(unless you named it
something else in the previous dialog box).  Clicking on the name selects what layer you
are working in.  Be sure layer 1 is selected.

Use the Window menu to bring the “blue wave” image to the forefront.  Go under the
Select menu and select all.  Go under the Edit menu and choose Define Pattern.  Now go
to the Window menu and bring the new image to the foreground.  Make sure you still
have layer 1 selected, then choose the marquee tool from the toolbox - the dotted square
in the top left corner. Click and hold on the square to bring up the other marquee tool
options.  Select the circle.  Now click and drag near the center of the image to make a
circle that covers about 4 of the repeating tiles of the grass pattern.  Try and center the
marquee in the entire image by moving it using the cursor keys.

Once your happy with the area selected, go to the Edit menu and select Fill.  It should
still be set to “Pattern”.  When you click OK, the circle is filled with blue waves.  Don’t
click anything else!  Without deselecting the circle, go to the File menu and save the file.
Call it “Template”.  Keep the circle selected and go back to the Layers palette.  Click on
the “background” layer to select it.  Click on the trash can at the lower right of the Layers
palette to delete the background layer.  This should leave you with only the circle filled



with the blue wave pattern and it should still be selected.  Go to the Edit menu and select
Fill.  Change the “use” option from “pattern” to “black” and click OK.  You should now
have a black circle where the blue waves were.  What you’ve created is the “reflection
map” that tells Myth where the water is.  Reflection maps can have only 2 colors, black
or white.  The white areas are interpreted as ground, the black water.  By using layers and
not deselecting the circle, you now have a Reflection map that tells Myth what area
should be water and it matches perfectly with the color map.

Go to the “Image” menu and select “modeàindexed color”.  You should see a dialog box
that has “Exact” for the “palette” and “2” for the number of colors.  Click OK.  Now go
to the File menu and select “Save As” (not Save!).  Name the file “water.pict”  and use
the pop up menu to change the file type to “PICT file” (not “PICT resource”).  Windows
users should make the file name “water.bmp” and the file type BMP.

Close the water map and open the “template” image you previously saved.  Your grass
and blue pond are back.  The blue wave pattern needs to be smoothed out, however.
Select Layer 1 in the Layers palette by clicking its name. Go to the Filter menu and
choose “ArtisticàCutout”.  In the dialog box that pops up set the number of levels to 4,
the edge simplicity to 4, and the edge fidelity to 2.  Click “OK” to make the pond.  The
dark and light blue you see now looks familiar to the water in the Gimble in the Wabe,
heh?  You can work with the eyedropper, paintbrush, rubber stamp, etc to make the
darker areas more natural looking and better arranged if you like.



Now its time to make our color map.  Save the file using the File menu in order to keep
an image with the layers still intact. We will make another copy that conforms to the
needs of Myth.  Go to the “Image” menu and select “Modeàindexed color”.  You will
receive an alert asking if you want to flatten the layers, select Yes.  Now you get the
dialog box for the indexed color settings.  For the palette, select “adaptive”. For the
number of colors select 240.  Some say you can get away with 256 although the Fear and
Loathing documentation says no.  If you leave it at 256 colors, be sure to select “8bits per
pixel” for the “color depth”.  Select “none”  for dither and “best” for color matching.
Click OK.  Now go to the File menu and select “Save As”.  Name the file
“hpctutorial.pict” and choose “PICT file” (not “PICT resource”) for the file type (BMP if
you have Windows). Your color map is ready!

Lets make the overhead map and netgame preview while we are here.  For the overhead
and preview maps you will be introduced to one of the most frustrating problems
encountered while working with images in Myth.  A brief explanation: “Indexed Color”
means that the colors used by the computer to make an image are put in a table (palette)
and then numbered according to their position in the table.  When the computer creates
the image it maps each pixel to the number that corresponds to the position in the table,
not the color that is there. If you move or change a color in the table, the number which
corresponds to that position won’t change, but the color will.  Every pixel in the image
that is mapped to that number (position) will now become a new color.  This can be used
for neat effects, but most of the time just makes your “color off”.  Volumes have been
written about color tables and working with them, I won’t delve any deeper here.

The only reason you need to know this for Myth is because when you import an image
into Fear, it changes the colors in your palette.  For the preview maps it makes the first
color black.  For the overhead map it makes the second color transparent.  As described
above, if a pixel in your image was mapped to position 1 and was not black, loading your
image into Fear will change all those pixels to black.  When you finally see your preview
in the options screen on bungie.net, it has black spots all over it!  For the overhead map,
any pixels mapped to the color in the second position will be transparent, making your
overhead map look like somebody shot it full of holes!

The workaround sounds simple.  Make sure the first color in your palette is black.  For
the overhead map, make sure no pixel in the image uses the second color in the palette.
Well… I wish I could say it was that easy.  Suffice it to say we have tried and are still
interested in a solution if anyone has a step by step way to do it on a Mac with Pshop 5
they would like to send us - thanks.

We can’t have holes in our images, however, so we will use Amber to fix them.  Amber
is a wonderful utility created by Vodi which will fix the problem on a Mac.  If you are
using Windows, Amber is not an option but also may not be necessary.  I have no
experience with the similar utility named Tahoe, but it can be downloaded at the same
site as Amber.  We will do this later in the tutorial.  For now, let’s create the images.



If you haven’t just fallen asleep you should still have the “hpctutorial.pict” image open.
Go to the “Image” menu and select “Image Size”.  In the dialog box that opens make sure
that “constrain proportions” is checked at the bottom and change the width to 128 pixels.
The height changes automatically to the same.  Click OK.  128 X 128 is a good size for
your overhead map.  Smaller or larger sizes will have the irritating effect of not going to
the proper area of the map when you click on the overhead image.  For odd shaped maps
or large ones, a scroll feature can be used, but that’s for another day.

If you’re using a Mac, you must save 2 versions of each the overhead map and netgame
preview in order to do our workaround in Amber.  You need a .pict and a .bmp of each.
If you are using Windows, simply save them once as .bmp.  The reason for using both on
the Mac will be described later.  Go to the File menu and select “Save As”.  If you’re on a
Mac, name the file “overhead.pict” and save it as a “PICT file”.  Now select “Save As”
again and name the file “overhead.bmp”.  Change the file type to BMP before saving.
When you click “save” you will get a dialog box asking if you want to save it as
“Windows” or “OS2”, select Windows. Click OK.

Now use the Image menu and change the image size again.  This time make it 90 X 90.
Don’t save the image at this size as we don’t want to overwrite the overhead map.  We
will just use it here at this size to be pasted into the netgame preview.

Now open a new file using the File menu.  Make this file 377 X 190 pixels – the size
needed for netgame previews.  Make it RGB mode again.  What you put in your netgame
preview is up to you.  Look at some on Bungie.net to see where the text covers the image
and what others have done.  Try and line things up so that they can be seen when the text
is over it.

For our tutorial map let’s just make a simple preview with what we have.  I’ve included
the file “arc.jpg” that can be put in the preview if you like. It is a screenshot from the
game.  In the final image included, I positioned it to demonstrate how you can make the
text present in the pregame hard to read because a light colored image is underneath it.
Open the arc.jpg file using the File menu. Bring the “blue wave” image to the front and
use the Select menu to Select All of it.  Use the Edit menu to define it as a pattern.  Now
bring the new netgame preview image to the front and use the Edit menu to Fill with the
pattern.  Bring the “hpcoverhead.bmp” image to the forefront and Select all of it.  Use the
Edit menu to Copy it and then bring the new netgame preview to the forefront.  Use the
Edit menu to Paste the overhead image into the new netgame preview.  Note that when
you paste it in, a new layer is created automatically.  With the layer selected, you can use
the pointer tool (top right of the toolbox) to drag the overhead image to wherever you
want it without effecting the blue wave pattern.  Put it in the upper right corner.  Copy
and paste the arc.jpg image the same way and put it near the left edge of the netgame
preview.  Finally, click on the Text tool in Photoshop (the letter “A” in the toolbox) and
then click near the lower right of the netgame preview image.  A dialog box comes up
with options for your text.  Make the Font “New York”, the size 24, and the color black.
Then type in the word “tutorial”.  Click OK.  You can use the pointer tool to separately
move any of the pasted images or text around simply by choosing their layer in the layers



palette.  For netgame previews, the top right is the largest area to be free from text.  The
next largest is the bottom right near the bottom edge.  Move your text there.  When you
are happy with your preview, go to the Image menu and change the mode to Indexed
Color.  Click yes to flatten the layers.  Again choose the Adaptive palette with 240 colors
and best color matching.  Now save the file as both a .pict and .bmp file as described
above for the overhead map.  Name the saved files “preview.pict” and “preview.bmp”.

 You are done in Photoshop.  Quit the application.  If it asks you to save the other files,
select “Don’t save” – otherwise you may overwrite your overhead map with the smaller
one you just pasted into the preview.

FEAR AND LOATHING

It’s time to see how our colormap will look in Myth.  If you’ve skipped the Photoshop
section or want to compare what you’ve created with those I did, look in the “completed
images” folder that was included with the tutorial.

Fear and Loathing were included by Bungie with Myth II to allow players to modify the
existing maps or to create new ones.  Any work you do in Fear or Loathing does not
modify the original tags from Myth II.  Instead, the modification is placed into your
“local” folder in the Myth II directory.  When Myth is played, tags in the local folder
override the ones that came with the game if they correspond to the same item, unit, etc.
Because the original game is not altered, simply removing the local folder should restore
things back to normal.  This can be a lifesaver if your mapmaking efforts suddenly result
in a crash every time you try to open Myth.  Fair warning – sometimes it doesn’t.  You
should make a backup of any saved games and recordings before you start mucking
around with either of these programs.

The local folder can also be moved to a directory outside of Myth II to provide a backup
of any mapmaking in progress.  As you will soon find out, Loathing can be quite unstable
and has very little in the way of “undo”.  For this reason, I make copies of the local folder



frequently into another set of folders, one for each “stage” of my work.  If something
goes awry and I can’t figure out why, I just replace the local folder in the Myth II
directory with the one from the most recent “stage” that I knew worked.  Sure beats
starting over.

If you’ve dabbled in Fear and Loathing already, go to the Myth II folder and either trash
the “local” folder or move it to another directory.  Now open Loathing.  When you open
Loathing you get a menu bar. Excitement. Go to the File menu and select “New”.  You
will get a dialog box that asks you to name the mesh.  Notice that, unlike other “save”
dialog boxes, you can’t maneuver around your hard drive with this one – you can only
save the mesh in the Myth II folder.  Name the mesh “HPC tutorial”.  Now you get a
dialog box asking what “media” type you want.  Remember that “media”=water, so even
though one of the options is “water”, they are all water!  Confused?  So am I.  Select
“water” and click OK.  Now you are presented with a dialog box that allows you to
maneuver around your hard drive in order to pick which color map to use.  Maneuver to
the “hpctutorial.pict”  and click OK.

You should now have 3 windows open.  The large window shows how the color map will
look while playing Myth.  Not bad, huh?  The smaller window acts like an overhead map
– click on it and you go to that position in the main window.  This small window also
shows the directional arrow for your location and will show the position of units, objects,
etc. as we add them.  The 3rd window is the toolbox window.

Move around in the main window using the same controls that you use in Myth. Pretty
neat!  You should notice 2 things:  1) The world is completely flat, and 2) When you go
to the edge the picture looks strange.  Let’s fix the second problem first.  The option



Loathing provides to fix this is to raise the edges so that they are at a 90 degree angle to
the floor. Go to the “Mesh” menu and select “raise mesh edges”.  This raises them about
20 units.  A “unit” is one triangle in the polygon mesh, which we will see later. You can
edit how far the edges are raised via the “Edit mesh edge raise amount” under the Mesh
menu.  Leave them at the default for now.

We also don’t want units walking or flying off of the edge of the map.  Myth controls
where units can go by defining “passability” for each polygon in the mesh.  We will do
more with this later. For now, go to the Mesh menu and highlight “Make mesh edges
impassable”.  See how easy this is?

Now lets work on the first problem and add some shape to our terrain.  Loathing provides
a number of tools for doing this.  You could import a “displacement map” using the
“Map” menu, but we don’t have one (A tutorial using Bryce 4 to create both a color map
and the corresponding displacement map at the same time will be out soon). For this
tutorial we will have to use the displacement tools, which are the three arrows pointing to
objects in the top row of the toolbox.  Click on the arrow pointing to the solid square box.
Notice that the main window now shows the polygons that make up your mesh.  You can
edit how the mesh is viewed and how it looks when you select it by going under the Edit
menu and choosing “View preferences”.  Leave all at the default for now.  Click on a
vertex in the mesh.  It will change color to indicate you’ve selected it.  Now click and
hold the mouse button while dragging the vertex up or down.  Cool!  You can move the
mesh up or down to make hills or valleys. To select more than one vertex, click in



between the grid and then drag.  Then release the mouse and click-drag directly on one of
the selected vertices to move them all at once. You can also use the  multiple selection
tool – the arrow pointing to the unfilled box.  The vertices selected by this tool follow a
rectangular shape.

The neatest tool is the one that looks like an arrow pointing to a volleyball, the
displacement brush. Click on this and the mesh polygons disappear from the main menu.
To see them while you use this tool go to the Edit menu, select “view preferences” and
change the option to “wireframe” (You can also just use the key combination
“Command/Windows + 2”).  The cursor in the main window for this tool is two large
circles that move around the map like a vacuum cleaner as you move the mouse.  Don’t
click yet!  This tool has a number of options which can be set under the Edit menu by
selecting “Tool Preferences”, or by using key commands.  In the “Tool Preferences”
dialog box, the “brush type” can be changed between a circle or square (F8 toggles).  The
tool options are “raise”, “flatten” and “filter”.  The Filter options are “elevation
adjustment”, “absolute elevation”, “smooth” and “noise”.  F7 toggles between the tool
options. F1-F4 selects the filter options.  The inner circle (or square) of the brush
displaces polygons in the mesh when you click the mouse according to what option you
have the brush set to.  You can decrease or increase the diameter of this circle using the
F9 or F10 keys, respectively.  You can also change the diameter in the Tool Preferences
menu.  The outer circle is the “Feather” area.  Polygons between this circle and the inner
circle are displaced in a tapered fashion to create a transition in elevation between the two
areas.  The diameter of the feathered area determines whether you have a broad, gradual
change, or a thin, abrupt change.  You vary the diameter of the outer circle using the F11
and F12 keys. or the Tool Preferences menu.

The displacement brush is fun, but can get you in trouble quickly.  If you have a fat index
finger with a slow reaction time, you will have a very bizarre looking mesh within a few
seconds.  Fortunately, the displacement brush is one of the few tools in Loathing for
which the “Undo” feature works.  If you’ve made a big mess using more than one step,
you can also use the “Flatten” feature to start over or fix the bad areas.  More on that in a
second.

Move the displacement brush to an area of the map near a corner.  Use the F8 key to
toggle through the options until “raise” is selected. Click the mouse and watch a bump
form.  Now hold it still and click again.  The bump gets larger.  Try sweeping around
while holding the mouse down and see what happens.  You can adjust how far the mesh
is displaced with each click by using the “+“ and  “-“ keys.  You can make the mesh
displace downwards instead of upwards by holding down the “shift” key as you click the
mouse.

The Raise option will continue to raise and lower the mesh until you release the mouse.
It also displaces things “dynamically”: When you move it around from side to side, new
polygons are raised the defined increment, while previously raised polygons continue to
be raised even further by the defined increment (so long as they are still under the brush).
With a little practice, you can create a multilevel displacement in the mesh such as you



would find in a rocky cliff or hillside.  I made small hills in each corner of the map with
the brush diameter roughly half that of our pond and the feather diameter roughly 2/3 the
size of the pond.  The displacement increment was set to 0.5.

The Flatten option is a nice way to clean up any mess.  Use the F8 key to toggle the
option to Flatten.  Now click and drag the Brush tool around any area you’ve displaced
and don’t like the result.  Each polygon returns to the “0” level – where they were when
we started.  Play around with the Raise and Flatten options until you are satisfied with the
terrain.  Don’t worry about the pond or the area around it.

Water usually settles into low lying areas, so let’s put ours in a uniform depression with
smooth sides.  We could use the raise tool with the Shift key, but my hands are too shaky
for that (they don’t shake in the operating room – I promise!).  The “Absolute Elevation”
Filter works much better.  Open the “Tool Preferences” dialog box via the “Edit” menu
and for Tool select “Filter”.  A Filter menu pops up – select “Absolute Elevation”.  Now
enter “-1” for the Absolute Elevation amount (not the Filter Effect Rate).  Click OK.

Scroll around in the main window until you have the entire pond within view.  Use the
“v” key to zoom out if necessary.  Now move the displacement brush over the pond and
use the F9 and F10 keys to adjust the brush’s inner circle diameter until it fits exactly the
diameter of the pond.  Don’t click yet!  Use the F11 and F12 keys to adjust the diameter
of the outer circle until it is nearly half again the size of the inner circle (Make the
distance between the 2 circles equal to about half the diameter of the pond - don’t send
me e-mails trying to correct my feeble grasp of geometric formulas, please).  Now, with
the inner circle exactly over the pond, click once.  Cool!  We have a bowl!  If you click
the mouse again it won’t do anything (unless you’ve moved the mouse) because the mesh
is already set to the “absolute” height.  The Absolute Elevation Filter is nice for making
ravines or ledges of the same height.  Simply set your elevation and sweep the tool across
the mesh.

The other options for the displacement brush are “Elevation Adjustment”, “Smooth”, and
“Noise”.  The Elevation Adjustment displaces the mesh from its current height by a set
amount.  The smooth and noise options create less or more variation, respectively, in the
displacement as you drag across the mesh.  Play with them later.  For now, keep the tool
set to Absolute Elevation with a displacement of –1 and the 2 circles left at their current
diameters.



Let’s mess up our beautiful bowl by importing the water map.  We could have imported it
before making any displacement adjustments.  Good advice.  I did it this way to make a
point – and to show you how to fix things if you do it this way.  Go to the “Map” menu
and select “Reflection MapàImport”.  In the dialog box that pops up, maneuver to the
“water.pict” file you created above in Photoshop and click “open”.  A few blinks and,
well, nothing happens. Why?  Knew you would ask.

To prove that the reflection map has been imported, click on the tool at the bottom right
of the toolbox (I have no clue what that icon is).  If necessary, maneuver around in the
main window until the center pond is visible.  See the highlighted polygons in the pond?
Showing you the highlighted polygons tells you that they are water.  That is the extent of
what this tool does.  Click the pointer tool – the top left arrow in the toolbox – to see the
surface of the water again.

For our rendered scene to show the “reflective” properties of the water, you have to add
light and shading.  No problem. Go to the “Map” menu and select “Shadow MapàAdd
Model Shading”.  The other options, “Basic Lighting” and “Add Mesh Shading”, are
done automatically if you choose the Add Model Shading option.  Other things you can
do in the Shadow Map menu include importing and exporting shadow maps, as well as
“Unprotecting” the submesh.  We haven’t protected it, so we don’t need to worry about
it.  A submesh is a 256 X 256 area of the map.  You can show the submeshes and select
one using the submesh selection tool – the sundial icon just under the pointer tool near
the top left of the toolbox.  I haven’t found much use for this yet, so I can’t tell you much
about it.

When you added shading, the main window should have gotten a little darker and the
water in the pond became all lumpy.  If it didn’t, save the mesh, close it, and reopen it via
the File menu. What happened to our nice bowl?  The short answer? - Importing the
water map messed it up - but why?

If you look under the “Mesh” menu, you will see 4 options for setting “heights”.  Two of
these options are for “Media”.  Hey!  Media=water, right?  Can water have a separate
height (displacement) than the mesh?  Sure it can.  If it didn’t, your Trow wouldn’t really
look like he was wading now, would he?  His feet have to be on a surface (the mesh)
while his waist is at the level of the water.

When you imported the reflection map, those areas of the mesh which corresponded to
the black part of the image were designated as “water” and reset to a height of zero.  The
lumpy part of our pond is just the mesh being displaced upwards out of the “bowl”.  We
just have to move the mesh back down.  The neat thing about water, or “media”, is that it
splits your color map as you separate it from the mesh.  The texture from your color map
becomes the surface of the water. Lowering the mesh below it creates a “physical space”
that has no surface. It is not seen, only used.  Because the water surface must have the
texture of your color map, you cannot raise the mesh to a level above it.  Try it.



This can be confusing.  To make things even worse, the Tools in Loathing don’t help.
As you click through the various tools, the color map will sometimes be rendered on the
surface of the water, other times, the mesh.  For the best idea of what your final map will
look like, click on the pointer tool.

Let’s set the height of the water to where we want it.  You can have water at multiple
levels in Myth by selecting areas and then using the “Set media height” option in the
Mesh menu. We have only one body of water, however, so we don’t need multiple levels.
In that case, selecting it is not necessary. Go to the Mesh menu and choose “Set all media
heights”.  Set the number to “-0.5” and click OK.  Our pond should now be slightly lower
than ground zero.  Now let’s set the mesh to where it is a smooth bowl again with the
bottom just under the surface of the water.  Select the displacement brush and make sure
it is still set to “Filter:Absolute Elevation” and the elevation set to “-1”.  The center circle
should still fit exactly on the pond and the outer circle be half again as big.  Before you
click, hit the F9 key a couple of times to make the inner circle a little bit smaller than the
pond.  This will create the effect of the water getting gradually deeper as the units wade
through.  Click the mouse button and viola!  We have a pond.  You may have to
close/open the mesh again to see the effect (save it!).

Our mesh is almost ready for units and scenery.  We have to tell Loathing what units can
wade through our pond first.  When you adjust the displacement of the mesh, Loathing
automatically calculates the “passability” for the new mesh level based on the depth
below ground zero or the rate of slope upwards.  For water, a depth of –1 below ground
zero is just beyond “dwarf depth” and into “human depth”.  What this means is that a
dwarf won’t go there if you try and move him to that spot during the game, but a berserk
will.  The various passabilites for depth range from dwarf depth (any unit will pass) to
“deep” (only wights and thrall).  For surfaces above the water, passabilites not only
control what units may pass, but also how the surface reacts to projectiles such as bombs,
fireballs, flame arrows, etc.  Click on the “passability tool which is just to the right of the
eyeball in the toolbox (again, I have no idea what this icon is).  The grid of polygons
returns to the main window with 2 shades of blue in our pond.   A menu pops up under
the toolbox with descriptions of each passability.  By default, flat ground is set to “grass”
(and the polygons are not shaded).  “Sloped” and “Steep” are gradations used for the
sides of hills, etc.  Steep polygons will only allow spiders or flying units such as Soulless
to pass.  “Walking Impassable” allows only flying units to pass, and “Flying Impassable”
allows no units to pass.  When we made the edges of the mesh “Impassable” earlier, it
designated the polygons as “Flying Impassable”.  The “Desert”, “Rocky”, “Marsh”,
“Snowy” and “Forest” options are variations on “Grass” that determine more the effect
on projectiles than passability.  The Desert setting makes fire less effective but bombs
more effective.  It also shows footprints when units move over it.  Rocky does not burn at
all, while explosives are much more effective (watch this one, your dorf may blow
himself up just by lighting a bottle – as you click to attack another unit:  BOOM!).
Marsh and Snow make both bombs and fire less effective as well as slow down some
smaller units movement.



The bottom of our pond was automatically set to “human depth”.  Let’s set it back to
dwarf depth.  Our dwarf’s head won’t go underwater because we lowered the surface of
the media as well.  The passability tool is once again a circle that  you can decrease or
increase the diameter of with the F9 and F10 keys, respectively.  Use F8 to toggle
between a circle or square.  If you hold the Shift key down as you press the mouse, it
only changes one pixel at a time.  Note that you can’t adjust the passabilty tool in the
Tool Preferences under the Edit menu.  You can, however, use the Undo feature.

Make the circle about a quarter of the size of the pond.  Click on “dwarf depth” in the
menu below the toolbox.  Click and hold the mouse as you drag around the pond and
change all the dark blue polygons to light blue.  If you accidentally change a polygon
which is in the grass, you can either use the Undo feature, or change the passability back
to “grass” using the tool..  Click on the pointer tool when you are done.

One more thing about the passability tool.  When you add models and certain scenery
items (i.e. trees) , the polygons where they are placed become designated impassable
(flying impassable) automatically.  This is good because you don’t (usually) want your
units walking through trees or houses.  If you put a few trees close together, however,
there may be a lagoon or narrow strip of polygons that are passable between them, yet too
narrow for a unit to get through.  This causes the units to get “stuck”.  One solution is to
just change the passability of the narrow area to Flying Impassable.  Part of the final
checklist for every map should be looking for these potential traps and eradicating them
by making them impassable. The typical unit requires a minimum of 3 “cells” (triangles)
in the polygon mesh to pass through.

It’s time to start adding units and scenery to our map.  Up until now most of the work has
been our own.  For the rest we will be mainly pilfering items from the existing Myth
archive.  It’s OK because they said we could.  Remember that.  Don’t pilfer anyone else’s
map or units unless they have given you explicit permission.



Creating new units sounds like fun, but is far too difficult for the first time mapmaker.
I’ll briefly show you how to modify existing Myth units here. As this tutorial is intended
to keep things simple, I also will not add every item possible such as Models,
Animations, or projectiles and will not set up every type of game.  My hope is that what I
do show you will give you enough of an idea as to how things work that you can figure
out the rest yourself.  The setup for them is similar.  Feel free to experiment.  If you need
further help you might want to check out one of the more extensive guides mentioned
earlier such as the Myth II Handbook.

I will describe briefly the other options: At the bottom left of the toolbox is a flag icon.
This is used for map “scripting” – code that controls actions and behaviors.  This is
mainly used in single player maps.  Some actions in network maps require scripting as
well, such as the delay that occurs before you gain control of the chickens in Gimble
Stampede.  Models and animations are placed from the house and windmill icons,
respectively.  They are different from scenery in that they have a “3D” surface - as you
rotate around them you see a different surface on each side.  Scenery items are 2D only.
As you rotate around them they rotate as well and remain facing towards you (Remember
the half-naked women in Duke Nukem?).  Models and Animations fit very specifically
into the mesh and can only be moved using the “Model” menu once they are placed.  You
can use the cursor keys to rotate them before placement.  Many of the Models available
are actually the specific steps, or “frames”, in an animation. This is why you will find 14
copies of “06 bridge” in the models list.  Level 6 is where your dwarves blow up the
bridge at the end.  Using one of these “frames” individually or trying to recreate the
animation is not something you will want to try in your first map.

Projectiles are placed using the icon just to the left of the speaker icon.  Projectiles are
just what they sound like, things that can fly or be thrown.  Many of them are “parts”
which result from an explosion.  Scroll down the list and you will see “berserk head”,
“berserk arm”, etc.  Again, many of these are part of an animation sequence in the single
player map levels.  The local projectile groups are placed by the tool just to the right of
the flag in the bottom left (a volcano?).  These are small snippets of animation.  The
leaves which fall from the trees in the Badlands, for example, are a local projectile group.

The remainder of the tools we will be using shortly.  Before that, however, we need to do
a few things in Fear.  Save your mesh, quit Loathing, and open Fear.  When you open
Fear, it polls your Myth II folder and creates a list of all the “tags” that are present.  This
may take a few seconds.  You should be presented with a list of folders starting with
“Ambient Sounds” and ending with “Wind”.  It is in Fear that you change the properties
of many aspects of the game, ranging from what words show up after “loading ____”
when you start a game to the animation sequence seen as a ghol runs across the terrain.
There are far too many tags and options to go through here.  I encourage you to read the
documentation supplied by Bungie and to look through the existing tags from the various
maps and units available.  Try and figure out what they do by the options they present.  A
word of warning:  There is no “save” under the File menu in Fear.  If you bring up a tag’s
menu of options and then close it by clicking “OK”, the change is saved.  Click the



“cancel” button if you’re “just looking”.  A modified tag will no longer have its name in
bold, as you will see in a minute.  If you’ve made a change and want to remove it, you
can either trash the entire “local” folder, or go to the specific folder inside it and trash the
modified tag.

Let’s set up our map so that we can have “connectors” – the barb wire between fence
posts.  Open the “Meshes” folder and scroll to the bottom.  See our “HPC tutorial” there?
It’s not bold, indicating it either a modified tag or a new one.  Double click it to open it.
How’s that for a few options?

We’ll work in the top left for now.  The “landscape” tells Myth what color map to use.
The “media” we set to “water” when we created the mesh.  The “mesh lighting” basically
has light, evening, or dark as options -“grassland’, “long desert shadow” or “catacombs
shadow”.  Leave it on “grassland” for now.  “Particle system” determines the weather.
Some of these have to be activated by a script, so leave it set to “none”.  “Ambient
sound” enables you to select a sound that is heard everywhere in the map.  It is not
localized.  You have a variety of options,  I chose “ambient marsh”.  The “Map
Description” is the name of your map in Fear.  This is what shows up after the “Loading”



when you start a game.  This “name” is also important if you want to create a duplicate of
your mesh and then, say, make a “Dark” version.  You can duplicate a mesh from the
Edit menu in Fear, but if you try to play it without creating a separate Map Description
for it - neither mesh will load.  We haven’t created our Map Description yet, so leave it
set to “No Tag”.  “Wind” doesn’t control the sound of wind, but actually whether your
map has real wind effects!  Sounds like fun, but leave it set to “No Tag” for now.  The
“narration sound” presents you with a lot of options (every sound tag in the sounds
folder) but is actually the narration at the beginning of each single player level.  It is not
used for network maps.  The “connectors” menu determines what is used when you
“create a connector” in Loathing.  It should currently be set to “no tag”, which is why we
had to stop here first.  Set it to “wire fence”.  The “Hints List” is used for single player
levels and selects which text to add to the hints.

Click the OK button to save the changes.  While we have Fear open, lets add our
overhead and netgame previews.  We will also modify a few things.  Close the “meshes”
window.  Now go to the File menu and select “Importàoverhead map”.  You will be
presented with a dialog box that asks you to name the overhead.  Call it “hpctutorial oh”.
Now you get a dialog box which allows you to select the file on your hard drive to
import.  If you are using a Mac, select the “overhead.pict” file.  If you are using
Windows, select the “overhead.bmp” file.  For Mac users our workaround with Amber
will eventually replace this image, but it’s easier to create the tag for it here.  The reason
you have to create 2 files is because the Mac version of Fear will only recognize the .pict
file, while Amber will only recognize the .bmp (depending on what file translator settings
you have on your Mac, you may have an option to import a .bmp using quicktime
translation in Fear – but it doesn’t fix the problem).  Now go to the File menu again and
select “ImportàNetgame Preview”.  Name it “hpctutorial prev” and select the
“preview.pict” file (.bmp in Windows).

We still need a “Map Description” for our map.  Any text that you see in Myth is
contained in a file called a “String List”.  You can edit any of the 311 “strings” in the
game or add your own.  Double click the “String List” folder to open it.  Now go to the
File menu and select “New Tag”.  You will be asked to name the tag, call it “HPC
tutorial”.  You will be presented with a dialog box that has an empty area in which you
can enter text.  Type in “HPC Tutorial” and don’t hit return/enter.  Click OK.  Hitting
return tells Fear that there is something in the next line.  If there isn’t –not good.

So long as we are in the String Lists, let’s modify one of the lines of text associated with
one of the units.  How about it’s name?  OK.  Scroll down until you find the string list
called “Dwarf Hero Name” and double click it.  Ever wonder why all the dwarf heroes
are called Andvari?  Heck, it’s the only option they have!  Let’s give them a few more.
Each time you start up your map, it will randomly select a name for the dwarf heroes
from this list.  Click to place the cursor at the end of “Andvari” and then hit Return.
Type in a couple more names of your choice.  Be sure to hit the Return key after each
name, but NOT after the last.  I entered “Ungar the Ox” and “Fat Blowpig”.  Click OK.
Notice that the tag for the dwarf hero name is no longer in bold.



Now that we’ve given them new names, why don’t we make the dwarf heroes a little
tougher?  Remember that units and wildlife are called “Monsters”  Close the String Lists
window and open the Monsters folder.  Now scroll down to the “dwarf hero” tag and
double click it.  Holy cow! Does every tag in Myth have this many options?

I won’t go through all of the options here.  Feel free to look around and try and figure out
what things do. Just be sure to hit “cancel” instead of “OK” for now.  Some things can be
changed and work fine.  Others cause nasty crashes or bizarre effects.

In the middle of the options do you see the box called “String Lists”?  The second one
down is how the “monster” dwarf hero calls on the names we just modified.  The
“sequences” and “sounds” over to the right, as well as the “collection” and “object” on
the top left,  are where you will find the references to the animations and sounds you will
see and hear when looking at the dwarf in a game.  The “projectile groups” are a
reference to the animation seen when the dwarf dies or explodes – the ‘dwarf pieces”.
We want the dwarf to have an even more powerful attack.  Look on the bottom left and
you will see the 2 “attacks” that the dwarf has.  For dwarf heroes, their molotov cocktail
attack is the same as that of the dwarf pathfinder’s.  Double click where it says “dwarf
pathfinder bottle lit” to edit it.  As you look through the flags and options, you can see
how the behavior of the dwarf’s attack is regulated.  One thing that is missing, however,
is the damage the bomb creates!  That’s because this is the tag for the “attack”-how the
dwarf looks and acts as he throws the thing.  The bottle itself is a “projectile”.  See at the
top left where it says “projectile” with “dwarf pathfinder bottle lit” as the selection?
There must be a tag somewhere in the projectile folder with the name “dwarf pathfinder
bottle lit”.

Before we leave this menu, however, let’s change some parameters of the dwarves
attacking style.  Why not make him shoot farther and take less time to reload?  Change
the “Maximum Range” to 20 and the “Recovery Time” to 1.  Machine gun bombs!  Click
OK for this menu as well as the Monster menu for the Dwarf Hero.  Notice how his name
is no longer in bold. Close the “Monsters” window and open the “Projectiles” folder.
Scroll down until you find the “dwarf pathfinder bottle lit” tag and double click it to open
it.  Another unwieldy menu!  Heck, even the physics of the “volume” is “unwieldy” (look
in middle of menu to get pun - that tag reference actually dictates whether other units
such as ghols can pick the item up off the ground.  If it is set to Unwieldy, they can’t).
Hey!  On the right side there is a button labeled “edit damage”.  Now we are cooking.
Click it.  The next menu is thankfully a little smaller.  The damage options near the top
left can be changed to give the bombs more oomph.  Don’t go too crazy!  Where it says
“Damage” change the left number to 8 and the right to 10.  If you go through other units
tags and look at the projectile settings for their attack, you’d see that the dwarven
pathfinder’s was already one of the most damaging.  We just made it even more vicious!
Click OK to accept and click OK in the main projectile menu.  Close the Projectiles
window.

What you’ve just done is only the tip of the iceberg as far as what you can do in Fear.
I’m sure you can now see how difficult creating a new unit and actually getting it to work



can be.  I also hope you want to play a little more and see what you can come up with.
One of the best ways to learn Fear is to try and find a sequence of tags that you think you
know what they do, modify them, and then see if you get the result you expected.  Be
prepared for crashes and bizarre events, but have fun!

Now let’s go back to Loathing and finish our mesh.  Quit Fear and open Loathing (they
can’t be open at the same time, btw).  Use the File menu to Open our mesh again (usually
at the bottom of the list).

Let’s add some sound first.  Double click on the speaker icon in the toolbox to open the
sounds menu.  The menu you see will be similar for all units and scenery.  You have to
add items to this list first before they can be placed on the mesh.  You setup each item’s
parameters as you add them to this list.  You can also modify them later by double
clicking on their name.  We don’t have any sounds yet, so click on the “add” button in the
bottom left.  You now can select any of the sounds that are used in Myth II.  At the top of
this list are the “ambient” sounds, the bottom ones are “random”.  The ‘ambient marsh”
that we selected in Fear will sound the same no matter where you are viewing the game
from.  Ambient sounds in this list are constantly playing, but can only be heard in a
localized area.  The random sounds here are also only heard in a localized area, but occur
sporadically. Another aside – if you look closely at the possible sounds, you will notice 3
that don’t seem to fit called “win screen”, “loss screen” and “splash screen”.  Do you like
the pounding drums that play after you win a single player level?  You can plug that
sound (Win Screen) right into your map!

We want the water in our pond to make a sound.  There isn’t an “ambient pond” sound,
but there is an “ambient lake”.  Highlight it and click “Open”.  You will get another
dialog box asking you to select the tag, which should already be set to “ambient lake”.
Click OK.  This second dialog box seems redundant and in this case it is.  Where it is



useful, however, is if you have placed a number of sounds on the mesh and then decide
you want them all to be something different.  You can just double click on the name in
this list and change the tag. Had you placed 40 ambient lake sounds throughout the map,
they would all change to the new sound.  Sure beats finding all 40, deleting them, then
adding 40 new ones!  This feature is most often used when changing groups of units.
Close the tag menu and Click OK to exit the Sound menu.   You should now see a small
box underneath the tool palette that says “Sound Sources”.  We only selected one sound,
so the only option available is ambient lake.  Maneuver to the pond in the main window
and, roughly in the center of it, click on the water.  The neat looking speaker with a
tongue that appears indicates that you have placed a sound there.  The “amla” tells you
the name of the sound. If you look at the small overhead view window, you will see that
two blue circles have appeared which indicate the areas where you can hear the sound.
The dark circle is the area where the sound is heard at full volume.  The light blue circle
indicates where it can no longer be heard.

You may need to center these circles around the pond.  It’s time to learn how to move
things in Loathing.  You can select any item in Loathing using the pointer tool.  If it can
be moved (remember that models can’t), you do so by holding down the Control/Alt key
and then dragging the item to where you want it.  You can also orient the item by clicking
on it and then dragging without using the Control/Alt key – much as you do in the game
itself.  You can drag a box around a group of items to select them as you do in the game,
but double clicking on a unit will not select all similar units – it will bring up a dialog box
we will use shortly. Clicking on more than one unit while holding down the shift key will
select multiple units at one time.

The problem is, if you change to the pointer tool, the blue circles go away!  If you want
them in view while centering the sound, you have to select the sound in the main window
using the sound tool itself.  You can then move it using the Control/Alt key as above.
The trick is to actually select the sound.  If you click just a little bit off, you will just
place a new one.  The best way to do this is to move your mouse over the sound until you
see its bordering box appear (this will be difficult to see against the blue background of



the pond, you may have to zoom in a little).  When it does, hold the mouse steady and
click the mouse down.  Now hold down the Control/Alt key and move the mouse until
the circles are centered.  Neat.  Now change to the pointer tool to prevent from
accidentally adding more sounds.

Now let’s add some scenery.  Scenery is much like your color map in that a lot of time
and effort can make the difference between what looks like a beautiful masterpiece
versus what looks like a something Bill Gates would come up with. Feel free to place any
objects you desire.  The selection process, movement, and orientation is similar to what
we just did for sound.  For this tutorial’s sake I will add a just a few items.  I will show
you  how to make connectors, however – one of the quirkiest steps in Loathing.

Double click on the tree icon in the toolbox (between the sundial and the house).  You get
another empty menu.  Click on the Add button and scroll down to the “01 post” item.
Highlight it and click open.  Once again you get a menu with the option to change the tag.
This one also asks you what game types the scenery will appear in – leave them all
checked.  The “Team” option should be set to “-1”. More on that in a minute.  Click OK.
Click OK again to close the scenery selection box.  You now can use the fence posts seen
in level 01 of the Myth II single player game.

You should now see a small box underneath the toolbox that says “scenery” and have “01
post (team –1) as the only option.  Click on the scenery icon in the toolbox if not.  Now
place 12 fence posts symmetrically around the pond, 3 each in the N, S, E, and W.  Use
the Control/Alt key to move them until they are lined up neatly.  As you add them using
the scenery tool, notice the blue dots that show up on the small overhead window.  You
can use this as a guide for lining them up, but, again, you have to be careful selecting
them when using the scenery tool.

When you are happy with their position, change to the pointer tool (if necessary).  The
following steps need to be followed exactly in order to make connectors.  If it doesn’t
work, go back to step 1 and try it again.  If it still doesn’t, check to be sure you selected a
tag for connectors in Fear.

1)Use the pointer tool and click on the ground to make sure you don’t have anything
selected.
2)Go to the Mesh menu and highlight “create new connector”.
3)Without opening any other menu or changing tools, click on one of the 3 fence posts on
any side of the pond.  Now hold down the shift key and click on the 2nd and 3rd fence
posts from that side so that all three are selected.
4)Go back to the “Mesh” menu.  The “create new connector” option should have a √next
to it.  Select that option again and let go of the mouse.



If you did it right, you will now see 3 wires between your fence posts.  You also now
know how to do something that many a frustrated mapmaker does not, based on the
number of posts in the forums asking about it.  The confusion arises from the √ mark.
Remember that it should not be there when you start the process and that making it go
away is what actually creates a new connector.  Go ahead and make connectors between
the groups of 3 fence posts on the other sides of the pond.

It’s finally time to add some units.  Double click the knight icon just to the right of the
house in the toolbox.  Once again you get the empty box.  Click “Add” to see the list of
available units.  Scrolling down this list should give you some insight into how the Myth
II game is organized.  The top of the list contains units with a number as part of their
name.  These units are used in the single player maps.  For the most part you can still use
them, but some may not behave the way you expected.  Below that you will find the units
which are used in the netgames that Bungie provides.  Some of the units have
descriptions after their name which can either be useful, or misleading.  For example, the
“archers (flameless)” are as advertised, no flame arrows (i.e. those used in Spider/Grave).
The “frog (stampede)”, on the other hand, will just sit there if you add them to a
stampede game and then try to move them to the center.  If you were to open the Monster
tag for “frog (stampede)” in Fear you would see that they can’t move at all. Under the
“Edit Sequences” menu, any sequence associated with movement has “no tag” selected.
Why they named the thing “Stampede” then, is just one of the many mysteries you will
come across as you dig through the guts of Myth II.  If you’re not sure what the name
means, or which one to select, try opening the map in Loathing that you think uses the
unit and see what you find.  For example: As you scroll down to the “Deer”, you’ll see
that there are 3 that have specific names – “explosive”, “hunted”, and “hunting”.  The
“explosive” deer sounds like the one from the secret level “A Long Awaited Drinking
Party”, but what about the other 2?  If you wanted to make a map where you could hunt
deer, would you use the “hunted” or the “hunting”?  Most people would say “hunted”,
right?  Well…. If you were to open the Gimble  mesh and check, you would see that the
deer that are used are the “hunting” ones.  Doggone em! Use this “look what they did”
method for any units or other aspects of the game that you’re not sure of.



Of course the first thing we have to add is our modified dwarf heroes. Scroll down to
“dwarf hero”, select it, and click “open”.  Another dialog box opens.  It again has the
option to change the unit tag. The “Team” box should say “0”, if not, make it so. We will
go through “teams” in a second. Down the right side you will see check boxes for each
game type you want the unit to appear in.  Leave them unchanged.  (This is how LMOTH
Untamed has only Dwarves, Jmen, Thrall and Wights – the other units used in that map
have the LMOTH box unchecked). The other options are: “uncontrollable” – the player
can’t control the unit in the game.  This does not make the unit “ambient life” in that the
unit is still part of the players team, they just can’t control them.  An example would be
the chickens in Gimble Stampede which start off as “uncontrollable” (blue box), then
change to controllable (green box).  Leave this unchecked.  “May be traded” – this box
must be checked if you want the unit to be available for Unit Trading at the beginning of
a netgame. Check it.  “May use veterans” – the units will keep their experience if they
survive to the next netgame (Veteran units will not work if the map or any player
changes).  Leave unchecked.  “Must use veterans” – this feature can be used to make a
unit show up only if veterans of the same kind survived the last game.  Leave it
unchecked.  “Is Ambient Life” – use this for “monsters” that are scenery such as birds,
deer, or peasants.  Hunted animals should also be set to “is Ambient Life”.  Leave this
unchecked.  “Is Hunted Creature” – allows the unit to be targeted when playing Hunting.
A combination of checking this box and only  the “hunting” box for “appears in
gametype” will make the unit only appear in the hunting game and be targetable– i.e. the
pigs in Proving Ground.  If you allow the unit to appear in other games as well, like the
birds in Spider Web, they will only be targetable in Hunting.  Leave this unchecked.
Click OK to accept.



We now have to discuss what the “team” number is.  Myth keeps track of what units and
objects are part of each team and creates scores for the network games based on this
number.  In single player maps, there are only 2 teams, good vs bad.  In network maps,
however, each player is part of a team and needs to have units that are assigned to a
specific number.  Where the confusion comes in is that the scenery and ambient life also
have team #s.  Ambient creatures have team numbers because they are part of the same
tags (Monsters) as fighting units.  Scenery has team #s because some of the scenery items
- the balls you use for balls on parade – have to be assigned to each team.  So how do you
make a scenery item or ambient creature not be assigned to a player’s team?  Remember
when we placed the fence posts and we set the team to “-1”?  That is the number that
Myth uses to identify the item as “background” – not on anyone’s team.  It uses this
number a little differently in single player maps, but we won’t let that bother us here.
This number is an important thing to check before you finalize your map.  Make sure all
the scenery and ambient creatures are set to “-1” (hunted creatures are also set to –1).
You can double click on their name in the selection list to change all of them at once.  If
you don’t have the numbers set correctly, you will end up with bizarre effects such as a
player having all their units destroyed, but still showing 50% of their army left because
the birds and fence posts are assigned to them.

The units that will engage in combat are assigned to teams beginning with team 0.  A four
player map would then have team 0, 1, 2, and 3.  When you place units in Loathing, you
must add each unit to your selection list one time for every team.  By making the team
number different for each, a new entry will appear on the list.

For simplicity, let’s make a 2 player map. We have available in our list dwarf heroes
assigned to team 0.  We need some assigned to team 1. Click the Add button again
(Double click the unit tool to open the list again, if necessary).  Scroll down to the dwarf
hero again and click Open.  You will get the same dialog box and the team number will
say “0”.  Change it to “1”.  Make the other settings are the same as we had for team 0’s
dwarf. (Check the “may be traded” box).  Click OK.  The unit selection list now shows
that you have dwarf hero available for team 0 and team 1, and that they can be traded
(“Tra/”).  It also tells you how many are placed on the map - the “count” should be 0 for
each right now.  Use this count during your final checklist at the end to make sure
everything came out even for each team.  It’s not necessary to make each team have the
same number of units, but it isn’t very fun to play if you don’t.  Click OK to close the list.

Go to the main window and maneuver until you are facing the top left corner of the map.
Back away until you have enough room to place a small army a little distance from the
wall.  Where you place units in Loathing is where they will start out when the game
begins.  With the unit tool active, click on the menu just below the toolbox and select
“dwarf hero (team 0)”.  Now pick a spot on the main screen and click to place a dwarf
hero.  Click just to the side of him to place another.

Use any method you wish to keep track of the starting spot for each team, but make sure
you do.  I try to make the top left team 0 and go clockwise around the map from there.



Since we are only going to place 2 teams, let’s make them start across from each other.
Go to the bottom right of the map to place team 1.  With the unit tool selected, click on
the menu just below the toolbox and select “dwarf hero (team 1)”.  Now click on the map
and place 2 dwarves.

You could stop here and simply play body count with these 4 dwarves, but let’s do some
more.  To add more units, double click on the unit tool.  If you added the dwarf heroes
correctly, your count should now show 2 for each.  If not, fix things by going back to the
main window and either deleting them (select them and hit delete/backspace) or adding
them.  If you have 4 for one of the teams and 0 for the other, you forgot to switch the
menu just under the toolbox before placing the second team.

Click the Add button in the unit list.  You can add any units you like, but follow along to
learn how to configure units correctly for games like assassin.  We have a deadly dwarf
hero, so lets give him some tough competition.  Scroll down until you see “Warlock
Hero”, select it and click Open.  Set the team to 0 and click the box for “may be traded”.
Click Open.  Repeat the procedure substituting team 1 for team 0.  Now find “Trow” and
add one for each team as well, allowing each to be traded.  What the heck, find “Alric”
(don’t use the “emperor” one) and add one for each team as well.  Make sure you click
the “may be traded” box for each.

Your unit list should now have 2 each of Dwarf Hero, Alric, Trow, and Warlock Hero.
Each should have “Tra/” after their name.  Double click on any unit name in the list
which is incorrect and fix it.  If you only have one listing for a particular unit, you may
have forgotten to change the team number.  Adding a unit to the list with every parameter
set exactly the same as that of one which is already there will simply make no change.
You can add the same type of unit to the same team so long as at least one of the
parameters is different.  For example, you could have Trow that can be unit traded, and
Trow that cannot.  Units that cannot be traded simply are present at the beginning of the
game, like the Wights in Gimble or Spider Web.

Some games, such as assassin, require units that are set up in a special way.  Let’s give
our super dwarves a challenge and make an Assassin game with the target Soulblighter.
Double click the unit tool to open the list (if you’ve closed it) and click Add.  As you
scroll down you will see a lot of different Soulblighter variations (it is his game, after all).
Choose the one without a number or description in parenthesis.  When you click Open,
set him up as follows:  Team = 0. Uncheck every box under “appears in netgame type”
except “Assassin”.  Make sure all of the boxes on the left side are not checked as well
(don’t allow him to be traded).  Click OK.  Repeat the process and add a Soulblighter to
team 1.  Make sure the other settings are the same.  Click OK to close the list.

Now go to the top left corner of the map in the main window again.  Use the menu under
the toolbox to make sure you are adding units assigned to team 0 and add 3 Trow, 1
Warlock Hero, 1 Alric, and 1 Soulblighter.  Arrange them so that they all can be seen in
the main window without zooming all the way out or panning.  Scary looking bunch,
aren’t they?



We still have to set up Unit Trading and have to designate Soulblighter as the assassin
target.  Setting him to appear only in Assassin is not enough.  Change to the pointer tool
and double click on the Soulblighter for team 0 in the main window (This usually spins
the unit around. Don’t bother turning him back yet as we will be clicking on a few more
units and will orient them all back at once).  Another menu!  At the top of this menu is
the option to set the minimum level for which the unit will appear.  This is how maps like
Leagues From Nowhere give you more units when you set the difficulty higher.  Leave it
set to timid.  The numbers in the boxes next to “I’, “J’, and “K” along with “Z” “yaw”
and “pitch” control the 3D positioning of your unit in relation to the mesh.  Changing
these is unlikely to have a desirable effect, so leave them as they are (If you change the
“Z” to a higher number the unit will start off above the ground, but will drop to the
ground as soon as the game begins if it is not a flying unit – try it sometime).   The
“invisible” box makes the unit just that, invisible.  Invisible units can have other units
move through them and cannot be controlled.  The main use for this feature is unit
trading, which we will do shortly.  The “stone” option sounds neat but doesn’t have much
use in network maps.  Try setting a unit as “stone” sometime and see what happens.  You
can use this option for stampede games in which the goal is the same flag for all teams.
Setting the flag to “stone” will prevent the flag from being “captured” and changing color
to that of the nearest unit.  “Detonates Immediately” can be used for things like the
Wights that explode at the beginning of Proving Grounds (be sure to set the team to –1 if
you try to set up something like that).  “Is invisible observer” is used mainly for scripted
events in single player levels.  Leave each of these options unchecked.  The one you want
is the “Is Netgame Target” – check that and click OK.  You just told Myth that
Soulblighter is the target for the Assassin game.  The only other game where you need to
designate a target is Stampede (called “Rugby” in Loathing – another mystery).  Scenery
items such as flags do not have to be designated as targets – that is done automatically.



For a stampede game, designate each unit (i.e. peasant) for which the goal is to bring
them to the flag as the Netgame Target.  Interestingly, for hunting targets you should not
designate the unit as a Netgame Target.  You set them up in the Unit Selection list by
designating them as “is ambient life” and “is hunted creature”.  Hunting targets are also
on team –1, not the individual teams.

One final word on Assassin and Stampede.  If you remember from playing the game, or
look through the network game meshes from Myth II, you will notice that the Assassin
target and the Stampede target are never the same unit and they don’t appear in other
games.  There must be a reason for this, right? If you designate a unit as the netgame
target, be sure that it is only set to appear in that particular game.  Failure to do so leads
to the infamous “Game Over” as soon as the game loads that has made it to a few 3rd

party maps out there.  Since hunting units are on team –1 and are not designated as
“netgame targets”, they will work correctly if added to multiple game types.  For
Stampede and Assassin, if you want to have the same type of unit be in multiple games
and be the target, you have to create a separate instance for each in the unit list.  Take a
look at the Fetch in the unit list of Spider Web for more details.

To allow unit trading you not only have to tell Myth which units can be traded, you also
have to define the number of units which are available as the default and the number that
can be added.  You do this by making some of the units “invisible”.  Visible units are
what you get as the default.  Invisible units can be traded for (if they have the “May Be
Traded” option checked).  Let’s make Alric and one of our Dwarf Hero units the ones
that can be traded for.  Double click on one of the Dwarf Heroes and make it invisible.
Now do the same for Alric.  When setting up Unit trading, try to keep in mind the cost of
each unit (available in the Monster tag in Fear – which can be changed) and what the
possible combinations are.  It does no good to make an expensive unit like a Trow
invisible and then not give the player enough of other kinds of units to trade up for it.
Try and match things up so that the combinations come out “even” as well. We won’t
worry about it too much here, as we just have a few units. We basically are giving the
player the option to drop a Trow (24pts) for Alric (16pts) and a Dwarf Hero (8pts) – a
good deal.



Our units for team 0 are set.  Using the pointer tool, click on the ground and drag around
them all to select them.  Now click and drag on one of them to orient them all towards the
middle of the map.  Now maneuver to the bottom right corner of the map in the main
window and repeat for team 1 what you just did for team 0 (Add the same number of
units, make soulblighter the netgame target, make 1 Dwarf Hero and Alric invisible, and
orient all units towards the middle).  Be sure you use the Team 1 options in the menu
below the toolbox. We are almost done!

If you stopped now you could play BC and Assassin.  No game would be complete
without Balls on Parade, however – King Adrock’s favorite game.  The balls and flags
that are part of many network game types are actually scenery.  The algorithm for setting
them up as team items is similar to what we just did for units.  Items that are unique to
each team (ball for Balls on Parade, Flag for Capture the Flag, Flag for Stampede if each
team gets their own destination) have to be added to the scenery list one time for each
team.  Items that are shared by all teams (flags for KOTH, LMOTH, Territories
andStampede with a common destination; balls for steal the bacon, and captures) only
need to be added once and set to team –1.  Flag Rally flags and scavenger hunt balls are
still set to team –1, but you must add one to the list for each one that appears in the game
(this is how the numbers are generated that come up in the scorecard while playing).



Double click on the scenery icon and click Add.  Scroll down until you see the variety of
“netgame” items.  The first is the “netgame LMOTH flag”.  Select it and click Open.
Make sure the team is set to –1.  You can leave all of the games checked in which it
appears.  When Bungie coded the netgame scenery items to work they also made Myth
smart enough to figure out which games they should appear in. Now add the “netgame
king of the hill flag” and set it to team –1 as well.  Add a “netgame balls on parade ball”
and set it for team 0.  Add another for team 1.  Click OK to close the scenery list.  Now
scroll to the pond and place one LMOTH flag and one KOTH flag there (be sure to select
them in the menu below the toolbox before clicking!) You can use the pointer tool along
with the Control/Alt key to move them to the center of the pond, as well as stack them so
close together that they look like one.  Now go to the top left corner.  Select the scenery
tool again and choose “netgame balls on parade ball (team 0)” in the menu below the
toolbox.  Click in front of your units in the main window to place the ball.  Now go to the
bottom right and place the BOP ball for team 1.

Now we can play a few games.  You can set up others if you like, otherwise we are done
in Loathing.  Ooops! Wait! – no one asked what the eyeball is for!  How could we miss
that?  The eyeball is the “camera” that creates the player’s view when the game is
actually played (Sometimes it’s also called the “observer”.  Unlike “media”, however, a
variety of unrelated things in Myth are called “observer”).  For multiplayer games, each
team gets their own camera.

Yep, you guessed it. Double click on the eyeball and click Add.  The options here are
simple, just enter the team number.  Add one camera for team 0 and one for team 1.  The
“cameras” come close to the “sounds” as far as how neat their marker looks in loathing.
Click somewhere on the main screen with the camera tool selected to see what I mean.
Now pan around and watch that spooky looking eyeball follow you.  We could drag and
orient the eyeballs like we did units and scenery to set them up, but the result would
probably look like my kids first attempt with the video camera.  Loathing has a neat
feature that lets you “frame” the view you want to be seen when the game starts.  Change
to the pointer tool and click on the eyeball you just placed on the mesh.  Hit the
delete/backspace key to remove it.  Now save the mesh and close it.  Use the File menu to
open it again.  If you want your camera to line up exactly with the view you are about to
frame, it is important that you do not hit the zoom keys “V” and “C” until we are done.  If
you back away from your units using the “V” key and then set the camera, the view seen
in the game will not be the same.  You can use any of the other keys from Myth to
maneuver around.   If you accidentally hit one of the zoom keys, close the mesh and
reopen it as we just did before placing your camera.  Move towards team 0 in the upper
left corner until you have a nice view of all the units framed in the main window.  Be sure
not to zoom in or zoom out. When you are happy with your view, click on the eyeball in
the toolbox.  In the menu that pops up below the toolbox select Team O.  Now go to the
“Mesh” menu at the top of the screen and select “drop observer”.  Back away (don’t
zoom out!) and there is an eyeball!  It’s all set to show what you just framed, so don’t
touch it.  Maneuver to the bottom right corner, frame your view, change to Team 1 in the
menu below the toolbox, and drop another observer.  Change to the pointer tool and save.



One more step and we are done in Loathing.  To prevent players from getting too close to
the edge of the map with the camera, you need to set the limits by which they are
“bound”.  Go under the Mesh menu and select “Set Mesh Parameters.  This brings up a
dialog box called “observer bounds” where you can enter 4 numbers.  The numbers tell
Myth how many units from the left, right, top and bottom edges to let someone panning
around get before putting the brakes on.  For most maps, putting 25 in each works OK.  If
you find that during the game you can move the camera too close to the edge and see too
many bizarre pixels, make the numbers a little larger.  If you find that units sent to a
corner of the map become no longer accessible (i.e. Badlands), make the numbers a little
smaller.  Click OK.

Now go through and double check that you have set up everything correctly. Make sure
there is only one camera for each team (check the “count”). Double click on the scenery
tool and make sure you have just one KOTH and one LMOTH flag.  You should have a
BOP ball for each team.  You should have 12 posts.  Now check that you have one
Soulblighter, three Trow, one Alric, one Warlock Hero, and 2 dwarf heroes for each
team.  Soulblighter should be the only unit that can’t be traded.  Look at the units in the
main window and maker sure that Alric and one Dwarf Hero are invisible and that
Soulblighter is set to the netgame target.  Reorient the units towards the center, if
necessary.  When your satisfied everything is correct, save the mesh and close Loathing.

Before we can play our map we need to set up a few more things in Fear.  For Mac users,
however, we need to make a stop in Amber first to fix our Netgame Preview and
Overhead Maps. Windows users can skip this part. Open Amber. Click the information
screen to get rid of it.  Go under the File menu and select Open.  Maneuver to your Myth
II folder, go into the “local” folder and then into the “collections” folder.  You should see
the “hpctutorial oh” and the “hpctutorial prev” tags that were created when we imported
the images into Fear.  Select the “hpctutorialprev” and click Open.

I won’t try to explain Amber short of saying it provides a way to directly edit the tags in
Myth II. Go to the “Collection” menu and select  “Replace bitmap”.  In the dialog box
that opens, maneuver to the “preview.bmp” (not the .pict) file and select it.  Click OK.
The next dialog box allows you to set a few options, leave them as is and click OK.  You
should now get a warning that tells you that the colors don’t match and asks if you want
to replace those in the tag with those from the file you are importing.  Click OK.  The fact
that your .pict and .bmp files have different color tables points to the source of the
problem noted above.  If only….

Save the preview tag and close it.  Now open the “hpctutorial oh”.  Again go to the
Collection menu and replace the bitmap.  Follow the same procedure as before except
select “overhead.bmp” to replace it.  Save it and quit Amber.

Just a few final steps!  Open Fear.  Open the Meshes folder and double click on HPC
tutorial to open it.  Just below the area where we previously made changes on the top left
is a box labeled “Collections”.  Click on the pop up menu for “pregame”, and scroll all
the way to the bottom.  Select “hpctutorial prev”.  Now go to the option for “Overhead



Map” and again scroll to the bottom. Select “hpctutorial oh”.  Now move to the center of
the Mesh menu where it says “Game Scoring Types”.  We have set up for BC, LMOTH,
BOP, KOTH, and Assassin, so check those.  Now go to the right side of the Mesh menu
where it says “Flags”.  Our map supports unit trading, so click that.  Click “is complete”
and “Can catch Fire” as well.  We are done!  Click OK.  Close the meshes window and
quit Fear.

Before we make our map a plugin, we should test it.  Fire up Myth II and go to the
Multiplayer game options.  Rather than log on Bungie.net, select “other” and host a
TCP/IP game.  Don’t worry if your modem is slower than Tobias’ wit, you’ll be the only
one in the game.  Try each game with the time set to a couple of minutes.  Make sure
everything works correctly including the flags and balls, the text (check your dwarf
names), and the Unit Trading.  Test the assassin game by bombing Soulblighter to death
with your new machine gun dwarves.  He is still tough, so give your self at least 3
minutes and control click on the ground under him rapidly for constant bombardment.
When he dies it’s pretty cool!  You can’t use Alric’s special weapon unless you are
playing someone else – bummer.



A couple things you can do while playing by yourself (watch that dirty mind!):

Have the dwarves make a stack of satchels around the ball in BOP and then control click
on the ground to blow them up.  Holy cow!  The ball will stop bouncing around in about
one minute.  Save the film and try to keep up with that thing!

Put your dwarves on a hill and move the rest of your units about a quarter of the map
away.  Select the dwarves and then control click on the ground under your other units.
What a range!  If the dwarves move before firing, move the other units a little closer.

Don’t touch the flag in LMOTH.  When the time runs out you will enter Sudden Death.
How long will it go?  Until you touch the flag.  Set up a Mac and a PC next to each other
trapped in this infinite game and see which one crashes first.  Aww, sorry PCs!

If something doesn’t work correctly, go back into Loathing or Fear and see if you can
figure out the problem.  I’ve enclosed a copy of the completed local folder for you to
check if you can’t locate the problem.  You will have to swap local folders in and out of
the Myth II directory in order to see each.

When your satisfied everything works correctly, it’s time to make a plugin.  Bad news -
this is very easy and doesn’t require a bunch of menus with multiple options.  Quit Myth
and open Fear.  Under the File menu highlight the option “Build Plugin”.  Enter “HPC
tutorial” under the name.  Leave the url as is.  Click OK.  Now quit Fear and go to your
Myth II folder.  Look in the plugins folder – there it is!

Congratulations!  You’ve just made a map that can be played between 2 players over
Bungie.net or a local network.  Feel free to polish it up, make sweeping changes, or toss
it in the trash.  Try it with a friend to see what kind of havoc Alric can create.

A final word on distributing maps.  When you create your own work of art and want to
make it available for others to play, you need to give Bungie credit for giving you the
opportunity.  Check page 78 of the Myth II Soulblighter Manual for details.  Create a
read me file for any map you distrubute with the line “Copyright 1998 in whole or in part
Bungie Software Producs Corporation.  Created with Bungie’s Fear and Loathing by:
(your name and e-mail address)”.

Good Luck!

Heal w Steel  hp∂
killer@killermac.com
http://www.killermac.com/hpd

http://www.killermac.com/hpd

	Goal
	General Tips
	Photoshop
	color map
	reflection map
	overhead map
	netgame preview

	LOATHING
	local folder
	new mesh
	edge of map
	terrain
	reflection map
	passability

	Fear
	meshes
	string lists
	monsters

	Back to Loathing
	sound
	scenery
	connectors
	units
	network game scenery
	observer

	Finalize in Fear
	Amber
	mesh
	plugin


